SharePoint 2013 – Standalone-Installation der Preview
avatar

Als passionierter SharePoint-Entwickler und -Anwender mit jahrelanger Expertise habe ich natürlich die neuste SharePoint Version 2013 (Wave 15) sehnsüchtig erwartet und mir die Preview unter http://technet.microsoft.com/de-de/evalcenter/hh973397.aspx  umgehend heruntergeladen und installiert.
Um einen ersten Blick auf die neuen Features und die Entwicklung eigener Komponenten werfen zu können, habe ich lediglich eine Standalone-Installation ausgewählt, die dafür vollkommen ausreichend ist.

Was ich allerdings zu dem Zeitpunkt nicht wusste, ist dass es bei der Standalone-Installation einige bekannte Fehler gibt, in die ich prompt reingelaufen bin. Damit Euch das nicht auch passiert und Ihr eine Menge Zeit spart, habe ich die Lösungen für Euch nachfolgend konsolidiert.

Die Fehler:

Fehler Nummer 1: Service running under Network…

Nach der erfolgreichen Installation muss der konfigurations-Wizard gestartet werden, bzw. startet automatisch. Dieser bricht allerdings nach kurzer Zeit mit dieser Meldung ab. Nach etwas Recherche hatte ich dann die Lösung gefunden:  Den Wizard nicht per Klick ausführen sondern über PowerShell!

Dazu über die SharePoint PowserShell Console folgenden Befehl ausführen:

C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\BIN>.\PSCONFIG.EXE -cmd Configdb create SkipRegisterAsDistributedCacheHost

clip_image002

Nach diesem Schritt muss der Konfigurations-Wizard erneut gestartet werden und läuft nun allerdings in Schritt 8 gleich wieder in den nächsten Fehler!

Fehler Nummer 2: The SDDL string….

clip_image003

Die Lösung für dieses Problem ist nachfolgend beschrieben

Es ist erforderlich ein verwaltetes Benutzerkonto anzulegen. Im Internet steht oft, dass dies über PowerShell gemacht werden kann. Dies hat allerdings bei mir nicht funktioniert. Daher habe ich den Managed Account über die SharePoint-Oberfläche angelegt.

Leider gibt es beim Anlegen des Managed Accounts in der Zentraladministration ebenfalls eine Fehlermeldung, da der Account „Network Service“ (mit dem ich in der Zentraladministration unterwegs bin) keine Rechte in der Registry hat. Daher ist es erforderlich mit „RegEdit“ die Registry aufzumachen und dort unter „HKLM\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\15.0\Secure\FarmAdmin” die volle Berechtigung für den Network Service-Account zu vergeben.

clip_image004

Nun kann man das verwaltete Benutzerkonto über die SharePoint-Oberfläche Fehler-frei anlegen und anschließend für den Search Service eintragen.

clip_image005

Würde man jetzt den Konfigurations-Wizard wieder laufen lassen, würde immer noch der Fehler auftreten! Aus diesem Grund muss man nun im Windows-Explorer zu dem Pfad „C:\Program Files\Microsoft Office Servers\15.0\Data\Office Server“ navigieren und das Verzeichnis suchen, das mit “Analytics” anfängt. (Dieses steht nach dem Auftreten der Fehlermeldung auch im SharePoint-Log.)

Jetzt das Verzeichnis mit der rechten Maustaste anklicken und wie folgt navigieren „Properties -> Sharing -> Advanced Sharing. In den erweiterten Eigenschaften „Share this folder‘ anhaken und auf „Permissions“ klicken. Dort den Search Service Account und die Gruppe „WSS_ADMIN_WPG“ mit „Full Control“ berechtigen. Danach den Wizard neu starten. Dieses Mal läuft der Konfigurations-Prozess sauber durch und SharePoint ist betriebsbereit.

Der Ärger während der Installation war ziemlich schnell verflogen. Ich finde die neue Version sehr gelungen und freue mich auf kommende Projekte mit diesem Produkt! Viel Spaß mit SP2013!!!

2 Gedanken zu “SharePoint 2013 – Standalone-Installation der Preview
avatar

  1. Pingback: SharePoint 2013 – Standalone-Installation der Preview - SharePoint Blogs in German - Bamboo Nation

Schreibe einen Kommentar